Opened 12 years ago

Closed 12 years ago

#1094 closed Bug (fixed)

When applying bold/italic to text in the end of a paragraph the non break space is also selected

Reported by: Jon Håvard Gundersen Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: Core : Styles Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc:

Description (last modified by Frederico Caldeira Knabben)

Steps to reproduce:

  1. Create a new paragraph
  2. Write a text
  3. Select all text in paragraph (but not paragraph)
  4. Apply bold or italic
  5. The non break space is selected
  6. Press delete and the whole paragraph is deleted and not only original selected word.

Tested in IE7 and nightly build.

Change History (5)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Confirmed IE added
Version: SVN

Just to clarify, there is no   at the end of the paragraph actually. That extra space is an indicator used by IE to tell that the hole paragraph.

I had some problems to reproduce it, because there was missing some information. The following steps are consistent:

  1. Load samples01.
  2. At the end of the preloaded text, hit enter to create a new paragraph.
  3. Type some text in the new paragraph.
  4. Now, with the mouse, select the entire text in the first paragraph.
  5. Apply "Bold". The leading space is selected.
  6. Hit [Del]. The entire paragraph is deleted.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles
Milestone: FCKeditor 2.5
Owner: set to Frederico Caldeira Knabben

I've made some tests locally, with the new style system, and it seams it has been fixed. So, we could expect the final fix to come with it.

comment:3 Changed 12 years ago by Jon Håvard Gundersen

OK, that sounds nice. Btw, how are the new style system progressing, are there many weeks before we can start testing it?

I apologize for the bad scenario, I will try do describe things more precisely in the future..

comment:4 in reply to:  3 Changed 12 years ago by Frederico Caldeira Knabben

Replying to jonhg:

OK, that sounds nice. Btw, how are the new style system progressing, are there many weeks before we can start testing it?

I think we'll start seeing some things during the next week.

I apologize for the bad scenario, I will try do describe things more precisely in the future..

No worries. The important is that you have opened the report. Then, if I would not be able to reproduce it, I would just ask for more info.

comment:5 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with [774].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy