Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1093 closed Bug (fixed)

Pressing enter inside inline tags does not create correct paragraphs

Reported by: Jon Håvard Gundersen Owned by:
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: Cc:

Description

Scenario:

  1. Go to nightly build version of FCKeditor
  2. Place cursor inside the strong text
  3. Press enter
  4. Press enter again - no new paragraphs is made

Maybe the fix for #1081 is source of this error?

Testing with IE7

Change History (4)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.5

Confirmed with IE7. Ok with FF.

comment:2 Changed 10 years ago by Martin Kou

I've traced the bug to the changeset [618]. Before [618], the bug does not occur.

The paragraphs in question are actually created, you can see them if you switch to Source mode or turn on the "Show Blocks" feature. They aren't shown because there's nothing in them.

comment:3 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: newclosed

Fixed with [725].

Click here for more info about our SVN system.

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

[725] introduced some issues with the enter key system (see #205). I have made a small change on it to handle <br> tags expansion too.

As I was a bit worried about all successive changes in fckdomrange_ie.js, I've reviewed all commits on it, so you may also find some minors changes in that changeset.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy