Opened 6 years ago

Closed 6 years ago

#10962 closed Bug (duplicate)

Speckie not working in Webspell checker editor - Spell check

Reported by: vijkand Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi

I have a webpage created of rich text editor with WebSpell checker attributes.

Now i have installed speckie. Ideally the speckie does the spell check immedietely after we type some incorrect words.

This is working fine in all my pages in website with text areas etc., but it is not working only in the place of rich texteditor where i have created with webspell checker.

Does it have any relevance with Ticket #10233?

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is exactly a duplicate of #10233.

Speckie only checks textareas and input fields while editor uses contenteditable=true elements. For example in iframed editor there is an iframe that holds document that has body set to contenteditable=true.
If you switch to source mode where textarea is used you will see that words get underlined.

In short speckie doesn't validate contenteditable=true elements. What you can do is reporting feature request to speckie.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy