Opened 6 years ago

Closed 6 years ago

#10980 closed Bug (duplicate)

IE9: 'resetDirty' function throws exception when called after 'setData' function

Reported by: IBM_RQM Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: Cc:

Description

Our usage -

  1. Create new instance of CKEditor (editor).
  2. On "instanceReady" event, calling editor.setData(data, setDataCallback);
  3. In 'setDataCallback' event, calling following functions -

editor.updateElement(); editor.resetDirty(); editor.resetUndo(); editor.focus();

Actual result: editor.resetDirty() function throwing exception - Uanble to get property "innerHTML" of undefined or null reference

In my initial investigation, it looks like the editor 'contentDom' is not fully ready.

Change History (1)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This problem can be reproduced in in all versions of IE.

  1. in CKEditor 3.x this was Unable to get property "innerHTML" of undefined or null reference
  2. In CKEditor 4.x Access denied is thrown.

Furthermore this isn't the only situation in which this happens thus I'm closing this issue as duplicate of #10501 and moving this TC there.

NOTE: Putting resetDirty in setTimeout method can be used to work around this issue.

editor.on( 'instanceReady', function( e )
				{				
					editor.setData('<p>abc</p>');
					window.setTimeout(function(){
					editor.resetDirty();
					editor.resetUndo();
					editor.focus(); 
					},10);
				});			
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy