Opened 6 years ago

Closed 5 years ago

#11031 closed Bug (fixed)

SCAYT issues

Reported by: Baris Sener Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.0
Keywords: Cc: tech@…, WebSpellChecker.net

Description

Go to http://ckeditor.com/demo

Delete everything in the editor. Hit "ctrl+b", and hit "a", hit "ctrl+b", and hit "a", hit "ctrl+b", and hit "a". Keep doing this for 10-15secs, and you'll see auto spell check will remove the bold automatically.

Sometimes it'll remove the cursor to the beginning of the word.

Attachments (1)

ck-editor.png (56.3 KB) - added by Baris Sener 6 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending

I wasn't able to reproduce this.

If possible please provide more details:

  • in which browser does it happen
  • Which sample have you used in demo page
  • could you perhaps provide screen-cast of the issue.

I suspect this might be this issue - https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/19#issuecomment-26412602

comment:2 Changed 6 years ago by Baris Sener

I use Firefox 24.0.

Full featured sample: http://ckeditor.com/demo#full

I attached a screen shot. In the screen shot, I was alternating between bold and normal. But you can see there are multiple bold letters back to back, and multiple normal letters back to back. It should have looked like this:

aaaaaaaaaaaaaaaa

Changed 6 years ago by Baris Sener

Attachment: ck-editor.png added

comment:3 Changed 6 years ago by Jakub Ś

Cc: tech@… WebSpellChecker.net added
Status: pendingconfirmed
Version: 3.0

@bsener yes you are right - I'm able to reproduce this issue on FF24 only.

  1. Go to replacebycode sample
  2. Clear contents with Ctrl+A Delete/Backspace (press backspace few times to make sure)
  3. Trun on SCAYT
  4. Press Ctrl+b, type 'a', Press Ctrl+b, type 'a' and so on and so on....

Result: You will not see expected result. Below is code that you can see with Firebug. Because commands/buttons state is changed there is more than one element wrapped in 'strong'. Additionally there are many orphan 'strong' elements.

<span data-scayt_word="aaaaaaaaaaaaaaaaaaa" data-scaytid="9"><strong>a</strong>a<strong>aa</strong>aa<strong>aa</strong>a<strong>a</strong>aa<strong>aaaa</strong>aa<strong>a</strong></span><strong></strong><strong></strong><strong></strong><br>

Problem can be reproduced in Firefox 24, from CKEditor 3.0 in both CKE 3.x and 4.x.
Because this is happening from CKE 3.0 I assume this is some SCAYT change causing this.

comment:4 Changed 6 years ago by Baris Sener

Is anyone looking into this?

comment:5 Changed 6 years ago by WebSpellChecker.net

Hello. Thank you for the reported issue. Currently we're looking for the solution. The behavior will be fixed in the upcoming release. The CKEditor's markup won't be affected by SCAYT for the described steps.

Last edited 6 years ago by WebSpellChecker.net (previous) (diff)

comment:6 Changed 6 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:7 Changed 5 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy