Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11050 closed Bug (invalid)

Widgets will not always copy whole object

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone:
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description

since: 4.3 until major

This bug does not occur constantly. What i have seen it can be reproduced if you will execute copy "rapidly".

  1. open any sample with CKEditor image2 plugin (i.e. plugins/image2/samples/image2.html)
  2. click on image to focus widget
  3. ctrl+c (copy widget)
  4. move caret somewhere else
  5. ctrl-v (paste widget)

If bug occured only text (or part) of caption will be copied. There might also line break be copied.

Change History (4)

comment:1 Changed 6 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: newassigned

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.3

comment:3 Changed 6 years ago by Marek Lewandowski

Resolution: invalid
Status: assignedclosed

It seems that it was caused by external app, clipboard manager.

comment:4 Changed 6 years ago by Wiktor Walc

Milestone: CKEditor 4.3
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy