Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11054 closed Bug (wontfix)

Pasting arrow from word converts to registered trademark symbol

Reported by: Stretto Consulting Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: Cc:

Description

If you use the "Copy from Word" function to copy the attached file contents it will convert the arrow into a registered trademark symbol. It needs to remain an arrow.

(text from document pasted below - please use the attached Word file as the actual source)

HNO3 + NaOH  NaNO3 + H2O

Attachments (6)

CKEditor-Bug.docx (12.6 KB) - added by Stretto Consulting 6 years ago.
screen1.png (115.6 KB) - added by Stretto Consulting 6 years ago.
screen2.png (146.4 KB) - added by Stretto Consulting 6 years ago.
screen3.png (118.1 KB) - added by Stretto Consulting 6 years ago.
nativePaste.png (57.0 KB) - added by Jakub Ś 6 years ago.
Capture.PNG (125.9 KB) - added by Stretto Consulting 6 years ago.
ICS Editor Working Example

Download all attachments as: .zip

Change History (16)

Changed 6 years ago by Stretto Consulting

Attachment: CKEditor-Bug.docx added

comment:1 Changed 6 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Version: 4.3 (GitHub - major)

The problem is that browser sees this docx code as registered trademark:

<p class="MsoNormal" style="margin: 0cm 0cm 10pt;"><span lang="EN-US" style='line-height: 115%; font-family: "Times New Roman","serif"; font-size: 12pt;'>HNO<sub>3</sub> + NaOH </span><span lang="EN-US" style='line-height: 115%; font-family: Symbol; font-size: 12pt; mso-ascii-font-family: "Times New Roman"; mso-hansi-font-family: "Times New Roman"; mso-bidi-font-family: "Times New Roman"; mso-char-type: symbol; mso-symbol-font-family: Symbol;'><span style="mso-char-type: symbol; mso-symbol-font-family: Symbol;">®</span></span><span lang="EN-US" style='line-height: 115%; font-family: "Times New Roman","serif"; font-size: 12pt;'>
NaNO<sub>3</sub> + H<sub>2</sub>O<o:p></o:p></span></p>

Please have a look at above code that browser sees. Native browser changes arrow to registered trademark sign and what CKEditor gets is code already processed by browser.

If browser sees this sign that way, there is nothing we can do here. This issue is a won't fix.

comment:2 Changed 6 years ago by Stretto Consulting

I hope you still get this comment, even though the ticket was closed. I am NOT convinced that this is a browser issue, because the GWT Rich Text Editor (link below) works just fine with the exact same browser and exact same content. This other editor is also JavaScript based and would only process the text after the native browser has provided content. There must be something else going on here. Also, if this character isn't converting correctly, I am sure there are others. Please compare against the editor linked below and you'll see that there must be a way to correctly capture the text.

Here is the ICS Editor used in the GWT: https://code.google.com/p/grails-gwt-smart/source/browse/trunk/web-app/gwt/com.unhook.myWidget/sc/modules/ISC_RichTextEditor.js?r=14

comment:3 Changed 6 years ago by Jakub Ś

I wil give it a try.

comment:4 Changed 6 years ago by Jakub Ś

I have done some research and ICS is actually Ice Cream Sandwich used fro mobiles. The problem is that we don't support mobiles just yet. We have some support for iOS (because it is quite stable) and that is about it.

Please tell me exactly where were you able to get arrow sign? In your mobile only or perhaps on desktop? I have tried CKEditor, plus some other rich text editors that are out there. None has produced Arrow character.

My guess is that you get this in mobile browser and that mobile browsers actually recognize this character while desktop does not.

comment:5 Changed 6 years ago by Stretto Consulting

Actually - this is all on Windows 7, using Chrome. So it is NOT mobile. Also, I think it is worth noting that the arrow pastes fine into the first window (the "paste from word") - but then when it saves it into the ckeditor main window, it changes the character. That is another indication that this is NOT a browser thing.

I have attached screenshots that show the whole process:

"screen1.png" - the word file on the left (also attached again for reference). The blank CKEditor window on the right. "screen2.png" - this demonstrates me copying / pasting into the "copy from Word" window. you'll notice that the arrow copies great into this first window! "screen3.png" - this is after clicking the "OK" on the "copy from Word" function. Now you'll see that the editor window changed the arrow to a trademark symbol :-(

Help!

Changed 6 years ago by Stretto Consulting

Attachment: screen1.png added

Changed 6 years ago by Stretto Consulting

Attachment: screen2.png added

Changed 6 years ago by Stretto Consulting

Attachment: screen3.png added

Changed 6 years ago by Jakub Ś

Attachment: nativePaste.png added

comment:6 Changed 6 years ago by Jakub Ś

Yes I can confirm that I see arrow when you make this initial paste but if you look at HTML code that browser sees and HTML that gets pasted to second input is in fact registered trademark character.

You have mentioned that it works in ICS Editor. I wasn't able to find any online demo and don't have much time to play with it on my local machine thus I would like to ask if you know or have any online demo that uses this editor and where it actually works?

comment:7 Changed 6 years ago by Stretto Consulting

Yes - I do have a working demonstration of the ICS Editor working in a browser. Unfortunately, this is a password-protected application. I will attach a screenshot for you to see, but that may not be very helpful. I would be happy to arrange for somebody to have access to do some troubleshooting via a screen-share, or some other arrangement. Just let me know how we might be able to arrange that.

Changed 6 years ago by Stretto Consulting

Attachment: Capture.PNG added

ICS Editor Working Example

comment:8 Changed 6 years ago by Jakub Ś

You could send me user and password with some guest access credentials to j.swiderski@….

comment:9 Changed 6 years ago by Jakub Ś

@stretto is there any chance you could email me credentials to this editor?

comment:10 Changed 6 years ago by Frederico Caldeira Knabben

Component: GeneralPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy