Opened 6 years ago

Closed 4 years ago

#11053 closed Bug (fixed)

SCAYT conflicts with FF selection when pasting and undoing

Reported by: cjarczew Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.2
Keywords: Firefox Cc: tech@…, WebSpellChecker.net

Description

SCAYT causes the entire document to be highlighted from the beginning up to the point of the cursor when I highlight text, paste some text and then press CTRL+Z or the undo toolbar option when highlighting from the start of a line.

Browser: FF 24.0

OS: Win 7

Reproducible location: Demo site and nightly build

I also tested with IE9.0.8112.16421(Undo doesn't work so I can't test, reproducible on the demo site) and Chrome 30.0.1599.101 m (Worked fine).

Steps to reproduce:

  1. Go to the demo site
  2. Enable SCAYT (No spelling mistakes required)
  3. Delete the content currently there, for whatever reason I can't reproduce with the default text
  4. I type or paste in a few lines of text like so:

Hi there how are you

Hi there how are you

Hi there how are you

Hi there how are you

  1. I then highlight part of the line beginning at the start of the line.
  2. Paste some content
  3. Press CTRL+Z
  4. Notice it will now highlight the entire document up to the cursor

Change History (6)

comment:1 Changed 6 years ago by Jakub Ś

Cc: tech@… WebSpellChecker.net added
Status: newconfirmed
Version: 3.2

This problem can be reproduced in FF24 from CKEditor 3.1.1 in both CKE 3.x and 4.x.

comment:2 Changed 6 years ago by Jakub Ś

Issue for IE was reported in #11056.

comment:3 Changed 6 years ago by cjarczew

Thanks for logging the IE one, I was going to do a search for it today but was assuming it was probably already logged. Quite surprised it wasn't noticed before.

comment:4 Changed 5 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:5 Changed 4 years ago by Wiktor Walc

Status: confirmedpending

I'm unable to reproduce it on FF36 / CKEditor 4.4.7 (demo page).

comment:6 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

I'm unable to reproduce this issue as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy