Opened 5 years ago

Closed 5 years ago

#11058 closed Bug (fixed)

IE8: Error 800a025e is thrown when deleting a row.

Reported by: Jakub Ś Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3.3
Component: General Version: 4.2.2
Keywords: IE8 Cc:

Description

  1. Insert 3x3 table.
  2. Fill in all cells with data.
  3. Go to middle (2x2 cell) and select from context menu "Insert Row Before".
  4. Fill in all new cells with data.
  5. Select all 3 cells with mouse and then select from context menu "Merge Cells".
  6. You will get one row.
  7. Right click on this new row and select "Row -> Delete Rows"

Result: in IE8 only error 800a025e is thrown.

Messgae: Error 800a025e
Line: 1542
URI: core/selection.js

Problem can be reproduced in IE8 from CKE 4.2.2.

Attachments (1)

2013-10-30_1701.swf (1.2 MB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by Jakub Ś

Attachment: 2013-10-30_1701.swf added

comment:1 Changed 5 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 5 years ago by Piotr Jasiun

There is a simpler scenario to get a error:

  1. open replacebyclass.html sample,
  2. click on "Commander" cell in "Mission crew" table,
  3. From the context menu select Row -> Delete Rows.

Result: "'compareDocumentPosition' is null or not an object"

Only deleting last row works properly.

Version 0, edited 5 years ago by Piotr Jasiun (next)

comment:3 Changed 5 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.3.3

comment:4 Changed 5 years ago by Olek Nowodziński

cc

comment:5 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:6 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

The bug was because of #10308. This hack fixed issue on IE10 but cases issue on IE8 (love IE). It seems to be enough to limit this fix only to IE10, because everything is fine on IE8 & IE9 without this fix.

The reason why tests did not show an error is because you need 4 rows in table (instead of 3) to have a crash removing second row (have I already mentioned that I love IE?). If you have only 3 rows you will get only small error in you console (and not in each case).

Changes in t/11058 and corresponding test branch.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_passed

LovIE!

comment:8 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy