Opened 5 years ago

Closed 5 years ago

#11074 closed Bug (fixed)

[IE] Inline widget dnd throws an exception

Reported by: Marek Lewandowski Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3
Keywords: Cc:

Description (last modified by Marek Lewandowski)

checked at major

I've reproduced issue on IE8 and IE10.
IE9 and IE11 are not affected by this bug though.

  1. open placeholder plugin sample (/plugins/placeholder/samples/placeholder.html)
  2. drag placeholder to other place using handler in top left corner

Expected result:
Placeholder should be moved

Current result:
Following exception is thrown:

SCRIPT16389: Unspecified error. 
plugin.js, line 1635 character 4

Change History (10)

comment:1 Changed 5 years ago by Marek Lewandowski

Description: modified (diff)

comment:2 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3
Status: newconfirmed

Definitely critical. AFAIK it was working, so first we need to check what git bisect will say.

comment:3 Changed 5 years ago by Piotrek Koszuliński

I was wrong - it never worked in IE8. It's because of extremely buggy IE's moveToPoint method. I'm afraid that we won't find a solution for that.

comment:4 Changed 5 years ago by Marek Lewandowski

Description: modified (diff)

comment:5 Changed 5 years ago by Piotr Jasiun

Works for me on IE10.

comment:6 Changed 5 years ago by Piotrek Koszuliński

And works for me too on IE10.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:8 Changed 5 years ago by Piotrek Koszuliński

I pushed a trivial fix to t/11074 - drag handler will be hidden for inline widgets on IE8. We have to wait for #10887 and #10933 to be able to fully manually test it and align automated tests.

comment:9 Changed 5 years ago by Piotrek Koszuliński

I reported #11086 as a follow up of this ticket.

comment:10 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Fixed on major with git:7642fa2 on dev and 9d1c2c1 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy