Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11086 closed New Feature (fixed)

[IE8] Re enable inline widgets DnD

Reported by: Piotrek Koszuliński Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3.2
Component: General Version: 4.3
Keywords: IE8 IE Cc:

Description (last modified by Piotrek Koszuliński)

We disabled it due to serious issues in #11074. We can try to re enable it using a little bit different approach. Instead of overwriting dragged content, we can let IE drop the image drag handler and replace it with the dragged widget.

Related ticket: #11158.

Change History (11)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.1CKEditor 4.3.2

comment:3 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:4 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

After re enable D&D works fine on IE8 (without error). It looks that git:6e1cc76 fixed also IE8 issue. Changes in t/11086 and corresponding test branch.

comment:5 Changed 5 years ago by Piotrek Koszuliński

It doesn't make sense to spend time on reviewing this ticket before we know how to fix #11158, because it may turn out that we'll have to rewrite dnd anyway.

comment:6 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_failed

Everything works fine when testing manually, but widget tests fail on IE8.

comment:7 Changed 5 years ago by Piotrek Koszuliński

I forgot to mention that I rebased both branches and force pushed them.

These tests are failing:

/dt/plugins/widget/widgetsintegration.html#test pasting upcasted widgets[[BR]]
/dt/plugins/widget/widgetsrepoapi.html#test widgets.destroy[[BR]]
/dt/plugins/widget/widgetsrepoapi.html#test widgets.checkWidgets draghandler re usage[[BR]]
/dt/plugins/widget/undo.html#test d&d inline widget

comment:8 Changed 5 years ago by Piotr Jasiun

Status: review_failedreview

A rebased both branches and fixed tests.

comment:9 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_failed

Block widgets dnd does not work now on IE8. It behaves like inline dnd but nothing happens.

comment:10 Changed 5 years ago by Piotrek Koszuliński

Status: review_failedreview_passed

I pushed a fix for issue mentioned in comment:9. Everything works fine now.

comment:11 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: review_passedclosed
Last edited 5 years ago by Piotr Jasiun (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy