Opened 5 years ago

Last modified 5 years ago

#11095 confirmed Bug

[IE8] Copying single widget does not work when using toolbar button

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version: 4.3 Beta
Keywords: IE8 Cc:

Description (last modified by Piotrek Koszuliński)

Follow up for #11082.

  1. Open image2 sample.
  2. Select widget.
  3. Click copy/cut button and accept security alert.

There's a big chance that selection was lost and widget wasn't copied.

Change History (6)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)

comment:2 Changed 5 years ago by Jakub Ś

Status: newconfirmed
Version: 4.3 (GitHub - major)4.3 Beta

I can confirm this issue in CKEditor 4.3 beta and latest major in IE8.

It is best to check this scenario when clipboard is empty.

Last edited 5 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 5 years ago by Jakub Ś

Continuation but for IE9/IE10 was reported in #11151.

Last edited 5 years ago by Jakub Ś (previous) (diff)

comment:4 Changed 5 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.3.1CKEditor 4.3.2

comment:5 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.2CKEditor 4.3.3

comment:6 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.3

Fixing this, when it's IE8 only issue and it requires ugly hacking, seems to be unreasonable atm.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy