Opened 5 years ago

Closed 5 years ago

#11082 closed Bug (fixed)

[IE] Widget is not copied/cut when using toolbar or ctx menu buttons

Reported by: Piotrek Koszuliński Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.3
Component: General Version: 4.3 Beta
Keywords: Cc:

Description

  1. Focus widget.
  2. Press "copy" button in toolbar and allow clipboard access.
  3. Try to paste - nothing get pasted.

PS. There's also an error thrown, but because this is pasted:

<div style="display: none;" data-cke-temp="1" data-cke-hidden-sel="1"> </div>

And since it's rather impossible to really copy element with display:none, I think that we can ignore this error.

Change History (4)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:2 Changed 5 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:3 Changed 5 years ago by Marek Lewandowski

Status: assignedreview

Created 2 branches t/11082a and t/11082b with potential solutions.

I decided that we will progress with t/11082b as a final solution.

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Cleaned up the code, R+ed and fixed on major with git:176e843.

I also notice that this solution usually does not work on IE8 when using toolbar buttons, because widget selection is lost. Seems to work well with ctx menu. Extracted to: #11095.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy