Opened 5 years ago

Closed 5 years ago

#11140 closed Bug (fixed)

[IE11] Dragging anchors does not work

Reported by: Piotrek Koszuliński Owned by: Piotr Jasiun
Priority: Normal Milestone: CKEditor 4.3.2
Component: General Version:
Keywords: IE11 Cc:

Description

  1. Open inlineall sample.
  2. Drag an anchor.
  3. It disappears after drop.

Change History (15)

comment:1 Changed 5 years ago by Piotr Jasiun

Status: newconfirmed

comment:2 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.1CKEditor 4.3.2

comment:3 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:4 Changed 5 years ago by Piotr Jasiun

Status: assignedreview

Changes in t/11140.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Please remove whitespaces from CSS strings.

comment:6 Changed 5 years ago by Piotr Jasiun

Done.

comment:7 Changed 5 years ago by Piotrek Koszuliński

I cannot reproduce this issue on master any more :|.

comment:8 in reply to:  7 Changed 5 years ago by Piotrek Koszuliński

Replying to Reinmar:

I cannot reproduce this issue on master any more :|.

Thank you, IE11, for resetting your compatibility view options. For some reason IE11 started loading pages in IE7 mode. Issue is still reproducible after I set correct mode.

comment:9 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_failed

Failed for two reasons.

  • There are padding and margin styles added without any explanation.
  • But most importantly - I think that we should simplify empty anchors using fake objects (we do this already on Webkit and Blink) - I created a ticket #11377 and pushed there a prototype of a patch. It works better than t/11140 because it doesn't hardcode anchor's height. More work is needed though, so we need to make a decision whether we choose t/11140 for now and work on #11377 in CKEditor 4.4, or whether we can work on it for 4.3.2.

comment:10 in reply to:  9 Changed 5 years ago by Frederico Caldeira Knabben

Replying to Reinmar:

we choose t/11140 for now and work on #11377 in CKEditor 4.4

I think that this is the most sensate way for it... it fits better on both the minor and major releases.

comment:11 Changed 5 years ago by Piotrek Koszuliński

Ok. I set 4.4 for #11377.

Regarding t/11140 - besides unjustified changes mentioned in comment:9 I also noticed that for other than unsupported Opera<12 we use vertical-align:text-bottom instead of middle. So perhaps the same value will be more adequate for style used for empty anchors. But first we need to have a TC for it.

comment:12 Changed 5 years ago by Piotr Jasiun

Status: review_failedreview

Other browsers has a combination of vertical-align:text-bottom; and height: 1.15em; what puts anchor in the middle. If we add only vertical-align:text-bottom; then anchor will looks different and bad (BTW: I realized that vertical-align:text-bottom; on IE11 is vertical-align:bottom; on Chrome and vice versa). Also without vertical-align we get different results on different IEs.

So my suggestion is to use vertical-align:text-bottom; and height: 1.15em; on IE as it works on FF and Chrome. I checked all versions of IE from 8 to 11 with this two rules anchors on all of them looks like on Chrome and FF.

I also removed padding and margin rules and putted ticked again on review.

comment:13 Changed 5 years ago by Piotrek Koszuliński

Rebased branch on master.

comment:14 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_failed

We should not change now the behaviour on other browsers, because we are going to rewrite all that very soon (#11377). Also, branch contained a patch with two issues - doubled height rule and unnecessary space in CSS.

comment:15 Changed 5 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_failedclosed

I decided to not waste more time and I chose the simplest solution. Issues was fixed on master with git:32485fa.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy