Opened 4 years ago

Last modified 4 years ago

#11169 confirmed Bug

Maximize not work

Reported by: psyafter Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.0
Keywords: Cc: psyafter@…

Description

When css class has "display:none", the "maximize" mode break a page and not work. Even despite the fact that the element has become visible (<div id="viewbar" style="display:block;">).

Here an example: http://jsfiddle.net/psyafter/P9k9S/2/

demo use:

  • jquery 1.10.2
  • ckeditor 4.3 (problem present in prev versions too)
  • jquery adapter

<style> #viewbar{ display:none; } </style>

<div id="viewbar" style="display:block;">

<textarea id="txa"></textarea>

</div>

<script type="text/javascript"> <![CDATA[ $().ready(function () {

var editor = $('#txa').ckeditor( function() { }, {});

}); ]]> </script>

Attachments (1)

replacebycode2.html (1.4 KB) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Jakub Ś

Attachment: replacebycode2.html added

comment:1 Changed 4 years ago by Jakub Ś

Keywords: maximize removed
Resolution: wontfix
Status: newclosed
  1. For Wrapper Div - user sets CSS style for id which then he overrides with inline style.
  2. When editor is maximized it assigns new inline styles to this wrapper div, writes them down somewhere and brings them back when editor is minimized.

The problem here is that once we remove inline styles and CSS styles assigned to id start working we can't minimize editor because we can't see it. This is quite an edge case :)

@psyafter one solution would be making editor not to touch styles placed in inline tag but depending on class or inline style this can cause some maximize errors.
I would rather suggest using classes (it will work then):

.viewbar{ display:none; } 

<div id="viewbar" style="display:block;" class="viewbar"> 

comment:2 Changed 4 years ago by Jakub Ś

Resolution: wontfix
Status: closedreopened

comment:3 Changed 4 years ago by Jakub Ś

Status: reopenedconfirmed
Version: 4.34.2

I got too quick here.

Solution (if it doesn't cause any maximize issues) could be adding display:block; or display:inline (depending on wrapper element) to overriding editor inline styles.

comment:4 Changed 4 years ago by psyafter

Cc: psyafter@… added
Version: 4.24.4.0

The problem still present in new 4.4 version

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy