Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11172 closed Bug (invalid)

In code-view, Zero-width space's are rendered, instead of being shown as code

Reported by: sirtet Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

To reproduce:

Copy the sample text from http://en.wikipedia.org/wiki/Zero-width_space

to the demo http://ckeditor.com/demo#standard

and switch to Source. Here, the zerowidth's should be shown as ​, but they are rendered as zero-width.

Pasting

aaaaaa​​bbbbbbbbbbbbbb​​ccccccccccccccccccccc​​ddddddddddddddddd​​eeeeeeeeeeeeeeeeeeeeeeeeee​​fffffffffffffffffff​​ggggggggggggggggggggg

into the code-view, switching to WYSIWYG and back, the entities are also no longer viewed, but rendered.

I see that rendering Zero-width space's is the normal behaviour of textarea's, but for "The best web text editor for everyone"'s Source button, i expect the same result as when looking at the page's source.

Source-editors like ACE http://ace.c9.io/build/kitchen-sink.html

and CodeMirror http://w8tcha.github.io/CKEditor-CodeMirror-Plugin/

show at least that there is something, but that's also not the full solution, if you want to see in source, what EXACTLY is going on in your Text.

Change History (3)

comment:1 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.3

comment:2 Changed 6 years ago by sirtet

Thanks.

I could apply

 config.entities_processNumerical = true;

in a jsfiddle, but not on my drupal7 site, filed an issue here: https://drupal.org/node/2138877

Upon searching for the reason, i had problems with testing in-browser: http://ckeditor.com/forums/Support/Modify-CKEDITOR.config-in-browser-and-allpy-the-changes

comment:3 Changed 6 years ago by Jakub Ś

  1. I think you need to use:
    config.entities = true;
    config.entities_processNumerical = true;
    
  2. Please also note that if you modify Full profile that uses full HTML then you need to use Full HTML in content area (for filtered HTML Drupal will apply its filters).

NOTE: space entity gets doubled. I have reported it here: #11185

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy