Opened 6 years ago

Closed 6 years ago

#11181 closed Bug (invalid)

Left mouse click on image opens image dialog

Reported by: peter Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: Teresa Monahan, Satya Minnekanti, Irina

Description

To reproduce the issue:

  1. Click insert image button from the toolbar
  2. Provide url, width and height
  3. Click ok button
  4. Double left mouse click on the image created.

Expected result: The image should be selected/highlighted.

Actual result: The image dialog is open.

This happens since 4.3 across all browsers. Also behaves the same for flash, iframe and table, where once you create a table if you click on the border of the table, the table dialog will pop up.

Change History (3)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Status: newpending

I cannot reproduce it. Single click selects the image and double click opens the image dialog. Are you sure that you don't have some a11y features enabled which translates single click to double click? No one has reported such behaviour.

comment:2 Changed 6 years ago by peter

In step 4 I am saying "double" click. As in 4.2 performing the double click wasn't had the same behaviour, I thought this could be wrong. Could you confirm please that double click on image, iframe, flash video and table's border is leading to opening the properties dialog.

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

@peter it has always worked that way - one click selects image, flash or iframe and double-click opens it. This is default behaviour in CKEditor.

It is possible that in earlier versions someone from your team has modified this behaviour to fit your product needs but this doesn't happen in editor by default.

I'm closing this issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy