Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11226 closed Bug (invalid)

Aligning image causes width and height to disappear (using Chrome)

Reported by: scarfie Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Using Chrome Version 31.0.1650.57 m (I have not tested this issue in any other browser.)

CKEditor Version 4.3

Open editor, click image icon, upload tab, choose file, send to server, OK. Aspect ratio is locked by default. Set width to 300. (Automatically sets height to 200) OK and SAVE. Aligning the picture either left or right causes the width and height to disappear. The picture reloads into editor original size (which may be huge). Tested using both the dropdown in the image properties, as well as the CKEditor alignment icons.

Change History (4)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Keywords: image properties lose height width after align removed
Status: newpending
Version: 4.3

I cannot reproduce this on Chrome Version 31.0.1650.57.

What I did:

  1. Opened replacebycode sample and http://ckeditor.com/demo#full and http://ckeditor.com/demo#widgets.
  2. Opened image dialog and uploaded/changed photo and then changed size.
  3. Tried to align image using align buttons, styles combo and dialog.
  4. Everything worked fine - widget and height haven't been lost.

Could you attach a sample (including CKEditor build on which this happens) so we could try to reproduce the issue?

comment:2 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I haven’t been able to reproduce this neither in local build nor in demo.

I'm closing this issue as invalid.

comment:3 Changed 5 years ago by scarfie

I was not able to reproduce this on the demo because it does not save. It's when we save the image (along with other text). Leave the page with the editor on it and come back later to edit the image. Once editing the alignment of the image, all of the rest of the properties disappear. For now, we have asked clients to remember to re-enter the image properties should they edit, but it does seem like they will eventually ask for a fix. Other than that the editor is awesome. We are using asp.net 4.5 (C#). Thank you!!!

comment:4 Changed 5 years ago by Piotrek Koszuliński

http://nightly.ckeditor.com/ - here you can save data and I don't lose dimensions at any point. Are you sure that it's not your backend code? And could you record a screencast + post your config?

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy