Opened 5 years ago

Closed 5 years ago

#11238 closed Bug (invalid)

New paragrahps added when saving bullet list with indented items

Reported by: Titus Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Running CKEDITOR in Wordpress, when I save a text with an existing bullet list that has indented items such as the below, the article gets returned (after saving) with an additional line with P marks, right before the indented bullet. The more often I save, the more paragraphs are created.

<ul>
	<li>&nbsp;</li>
	<li>adalksdjaskldjasld alksdj asldkajd lak</li>
	<li>adalksdjaskldjasld alksdj asldkajd lak
	<ul>
		<li>adalksdjaskldjasld alksdj asldkajd lak</li>
		<li>adalksdjaskldjasld alksdj asldkajd lak</li>
	</ul>
	</li>
	<li>adalksdjaskldjasld alksdj asldkajd lak</li>
	<li>adalksdjaskldjasld alksdj asldkajd lak</li>
	<li>&nbsp;</li>
</ul>

Change History (2)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Keywords: paragraph bullet list removed
Status: newpending
Version: 4.0

I cannot reproduce this on clean CKEditor. Can you do it on http://ckeditor.com/demo? I was checking by switching between modes, what simulates saving and loading data.

comment:2 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Editor itself doesn't have anything with data saving so this is most likely something on Wordpress side.
I have tried reproducing this issue on plain AJAX sample where getData is called (can be used to put data into request or write data somewhere else) and there was nothing wrong.

I'm closing this issue as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy