Opened 5 years ago

Closed 4 years ago

#11245 closed Bug (fixed)

Correct spell menu not open on right clicking misspelled word, only if 'config.enterMode = CKEDITOR.ENTER_BR;' line added in your config.js file

Reported by: Mahavir Dhruv Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 4.3
Keywords: Cc: mahavir@…

Description

Recently, I update CKEditor 4.0 to 4.3, because 4.0 not properly working in IE 11.

But in CKEditor 4.3 I am facing an issue with spell checker context menu in Google Chrome.

In my config.js file I set 'enterMode' to 'BR'(ENTER_BR) to override default mode 'P'(ENTER_P). Shown below:

config.enterMode = CKEDITOR.ENTER_BR;

And when I enable spell check from toolbar, it just showing me context menu (on right click) with only 'paste' option, not showing correct spell list.

But when I remove the code config.enterMode = CKEDITOR.ENTER_BR; from config.js file, then spell check context menu show correctly with correct spell list.

NOTE: I am facing this issue with Google Chrome.

Thanks!

Attachments (2)

Selection_139.png (32.4 KB) - added by Piotrek Koszuliński 5 years ago.
replacebycode3.html (1.4 KB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newpending

Works for me on 4.3 on Google Chrome in ENTER_BR mode of course:

Could you attach a test case and CKEditor package on which this happens?

Last edited 5 years ago by Piotrek Koszuliński (previous) (diff)

Changed 5 years ago by Piotrek Koszuliński

Attachment: Selection_139.png added

comment:2 Changed 5 years ago by Jakub Ś

Status: pendingconfirmed

Problem can be reproduced in Webkit, Blink and IE (works fine in Firefox) from CKEditor 4.3.

To reproduce:

  1. Load attached file (there are enter_BR and empty editor contents)
  2. Enable scayt
  3. Type two misspelled words separated with Enter
  4. Wait until there is red underline and right-click on words.

Changed 5 years ago by Jakub Ś

Attachment: replacebycode3.html added

comment:4 Changed 5 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:5 Changed 4 years ago by Wiktor Walc

Resolution: fixed
Status: confirmedclosed

The issue has been fixed in new version (v. 3) of SCAYT plugin for CKEditor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy