Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#11287 closed Bug (fixed)

[Chrome, inline editor] Ctrl+A after selecting Page Break selects an entire page instead of the editor body content

Reported by: peter Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0 Beta
Keywords: IBM Webkit Blink Cc: Teresa Monahan, Satya Minnekanti, Irina

Description

Reproduce the issue:

  1. Open any inline based editor sample in Chrome.
  2. Type in or paste some text in the editor body.
  3. Split the text with Page break, by using the icon from the toolbar.
  4. Left mouse click on the Page break.
  5. CTRL + A

Expected result:

The editor body content should be selected/highlighted .

Actual result:

The entire page content is selected(outside the editor body)

Reproducible only in Chrome in 4.3 version

Change History (5)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Status: newconfirmed

Confirmed on Chrome on 4.3 and 4.2.2. I haven't checked previous versions, but most likely it's not a regression.

Note: it cannot be reproduced on widgets and if page break was selected by left/right arrow keys navigation (CKEditor makes fake selection in this case). So the solution could be to rewrite pagebreak as a widget.

comment:2 Changed 5 years ago by Jakub Ś

Keywords: Webkit Blink added
Version: 4.0 Beta

Problem can be reproduced in Blink and Webkit from CKEditor 4.0 beta.

NOTE: Should page breaks be even used in inline editors? They look ok in HTML but won't work for printing. Since inline editor edits part of larger page then page-breaks won't do their job when it comes to printing. This makes sense - why should some inner/nested div that is part of larger structure break the page?
If page-breaks are used in HTML then they should be left but if they are only used for printing then they should be removed just like print button.

comment:3 Changed 5 years ago by Piotrek Koszuliński

@j.swiderski: Page breaks make the same sense in inline editing as in framed editing. Finally, in both cases content produced by editor ends in some web page so it's the same situation.

Regarding this issue - pagebreak is a non-editable element, so apparently, when it's focused, native CTRL+A "leaves" main editable. This is a bug in Webkit&Blink, but it will be the easiest to fix it by making pagebreak a widget.

comment:4 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Not any more reproducible.

comment:5 Changed 3 years ago by Anna Tomanek

Summary: Chrome, inline editor: Page break - CTRL+A,instead selecting the editor body content it selecting the entire page[Chrome, inline editor] Ctrl+A after selecting Page Break selects an entire page instead of the editor body content
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy