Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11299 closed Bug (wontfix)

[IE7] Editor does not load

Reported by: timr Owned by:
Priority: Normal Milestone:
Component: General Version: 4.3.1
Keywords: IE7 Cc:

Description

Descriptive summary - The textarea is hidden, but CKEditor does not load in native IE7 (tested using a Virtual Machine), even on the demo page. It works in IE11's "IE7 mode".

Steps to reproduce Load a native instance of IE7, not compatibility mode and go to the demo page.

Browser and OS - IE7, Virtual Machine with XP mode

Change History (4)

comment:1 Changed 5 years ago by timr

Actually, you can also reproduce this by changing the user agent string to IE7 using F12 tools. This is also happening with IE6

Last edited 5 years ago by timr (previous) (diff)

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed

IE7 and IE6 are not supported any more. The last version which supported IE7 was 4.1.x and the last which supported IE6 was 3.6.x.

comment:3 in reply to:  2 Changed 5 years ago by timr

Replying to Reinmar:

IE7 and IE6 are not supported any more. The last version which supported IE7 was 4.1.x and the last which supported IE6 was 3.6.x.

Thanks for replying, that's a real shame though as a lot of corporates are still using IE7. IE6 maybe not, but losing IE7 support may mean we need to look into using a different editor. May I ask why that decision was taken, was it too difficult to continue supporting it?

comment:4 Changed 5 years ago by Piotrek Koszuliński

Supporting every older browser is a big effort. The older the bigger the effort is, but even IE8 pretty often gives us a hard time. If we still supported IE7, then we would support an enormous range of IE7, IE8, IE9, IE10, IE11 and IE5 QM. All of those browsers/modes differ (significantly) and require time to fix bugs and test editor on them. That's why every (few) year(s) we drop support for some of them.

According to http://caniuse.com/usage_table.php IE7 is used by 0.44% of users - we don't see a reason why other users have to suffer worse experience because of that 0.44%. Especially that it's still possible to download previous versions of CKEditor which work on IE7 and even IE6.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy