Opened 5 years ago

Closed 5 years ago

#11314 closed Bug (invalid)

hidden first dialog tab

Reported by: Bill Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I have created a dialog which has 3 tab. I want to hidden first tab when missing some config by "contents: [ {hidden: true". then it should auto active second tab.

however, the problem is, tab is hidden. but first tab's content still show. and the second tab is not active.

Change History (2)

comment:1 Changed 5 years ago by Bill

solution:

onShow: function() {
	if(!editor.config.xxxxx){
		this.hidePage( 'first' );
		this.selectPage( 'second' );
	}
}

however, it is better impl this: when config hidden first tab, it should hidden the content, and show the second tab?

comment:2 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Current design for dialog defines tabs and contents inside them. Currently we don't offer exchanging content in single tab.

I'm sorry but this is not a bug as CKEditor API gives you solution here.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy