Opened 6 years ago

Closed 6 years ago

#11315 closed Bug (duplicate)

core/lang.js: crash in callback when language fails to load

Reported by: Ger Hobbelt Owned by:
Priority: Normal Milestone:
Component: UI : Language Version:
Keywords: Cc:

Description

How to reproduce:

  • run /samples/inlinetextarea.html
  • make server FAIL to deliver the language file en.js (happened to me when server timed out due to heavy load and/or wakeup (local machine))

Cause:

callback does not check the success/fail flag sent by the CKEDITOR.scriptLoader

Quick fix:

pull request will be listed below.

Change History (2)

comment:2 Changed 6 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: newclosed
Version: 4.3.2 (GitHub - master)

I generalised your ticket to: #11318. Let me close this one as a duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy