Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11317 closed Bug (invalid)

ACF is NOT working, no matching anything

Reported by: santaclaus21 Owned by:
Priority: Normal Milestone:
Component: Core : Parser Version: 4.3.1
Keywords: Cc:

Description

Firstly - don't try to say "everything is fine" because it isn't. It's BUG.

initialize:

editor = CKEDITOR.replace( 'opis_' + ec , {
	allowedContent: 'p h1{text-align}; a[!href]; p(tip)'
	} );

html source:

<p style="font-weight: bold;">Z okazji zbliżających się Świąt pragniemy życzyć Państwu pogody ducha, radości serca, zdrowia, szczęścia pomyślności i wszystkiego co najlepsze, w Nowy<strong><a href="http://uuuuu" style="margin-left: 100px;" target="_blank">m 2014 Roku !</a></strong></p>

console log:

0: Object
attributes: null
classes: null
elements: Object
h1: true
p: true
__proto__: Object
featureName: "config"
'''match: null'''
propertiesOnly: false
requiredAttributes: null
requiredClasses: null
requiredStyles: null
styles: Object
__proto__: Object
(...)

ACF isn't trying to filter anything.

Attachments (2)

cke1.PNG (36.5 KB) - added by santaclaus21 5 years ago.
Selection_155.png (140.9 KB) - added by Anna Tomanek 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by santaclaus21

Attachment: cke1.PNG added

Changed 5 years ago by Anna Tomanek

Attachment: Selection_155.png added

comment:1 Changed 5 years ago by Anna Tomanek

Status: newpending

As you can see on the attached screenshot, it works for me. Are you sure that you haven't included any 3rd party plugins that disabled ACF? I can see that you use some sort of replacement for our sourcearea.

comment:2 Changed 5 years ago by santaclaus21

Yes I'm sure: You can try it on: http://autobusywieden.pl/admin/ (L/P: cke/cke) - click "rozwiń" (href) anywhere. Thank you for support because Reinmar had closed my issues about ACF as invalid...

my build-config (but I was trying a lot of another, including minimal config) ACF wasn't work :(

/**
 * @license Copyright (c) 2003-2013, CKSource - Frederico Knabben. All rights reserved.
 * For licensing, see LICENSE.html or http://ckeditor.com/license
 */

/**
 * This file was added automatically by CKEditor builder.
 * You may re-use it at any time at http://ckeditor.com/builder to build CKEditor again.
 * 
 * NOTE: 
 *    This file is not used by CKEditor, you may remove it.
 *    Changing this file will not change your CKEditor configuration.
 */

var CKBUILDER_CONFIG = {
	skin: 'moono',
	preset: 'full',
	ignore: [
		'dev',
		'.gitignore',
		'.gitattributes',
		'README.md',
		'.mailmap'
	],
	plugins : {
		'dialogadvtab' : 1,
		'basicstyles' : 1,
		'blockquote' : 1,
		'clipboard' : 1,
		'colorbutton' : 1,
		'colordialog' : 1,
		'contextmenu' : 1,
		'div' : 1,
		'resize' : 1,
		'toolbar' : 1,
		'elementspath' : 1,
		'enterkey' : 1,
		'entities' : 1,
		'filebrowser' : 1,
		'find' : 1,
		'font' : 1,
		'format' : 1,
		'htmlwriter' : 1,
		'horizontalrule' : 1,
		'wysiwygarea' : 1,
		'image' : 1,
		'indent' : 1,
		'justify' : 1,
		'link' : 1,
		'list' : 1,
		'liststyle' : 1,
		'magicline' : 1,
		'maximize' : 1,
		'pastetext' : 1,
		'pastefromword' : 1,
		'removeformat' : 1,
		'selectall' : 1,
		'showblocks' : 1,
		'showborders' : 1,
		'stylescombo' : 1,
		'tab' : 1,
		'table' : 1,
		'tabletools' : 1,
		'undo' : 1,
		'dialog' : 1,
		'dialogui' : 1,
		'panelbutton' : 1,
		'button' : 1,
		'floatpanel' : 1,
		'panel' : 1,
		'menu' : 1,
		'popup' : 1,
		'fakeobjects' : 1,
		'richcombo' : 1,
		'listblock' : 1,
		'stylesheetparser' : 1,
		'sourcedialog' : 1,
		'sourcearea' : 1,
		'tableresize' : 1,
		'indentlist' : 1,
		'codemirror' : 1,
		'textselection' : 1,
		'save' : 1
	},
	languages : {
		'en' : 1,
		'pl' : 1
	}
};

Last edited 5 years ago by santaclaus21 (previous) (diff)

comment:3 Changed 5 years ago by Anna Tomanek

Keywords: acf paste word filter removed

First of all, Reinmar closed your tickets as invalid as they were invalid. Period.

I can see you are using some third-party plugins (for example CodeMirror and TextSelection). Like I said before, it seems that one of the third-party plugins is the cause here as we cannot reproduce it with our standard builds and at the same time, we do not provide support for 3rd party products.

Install one of the pre-defined presets (Basic, Standard, Full) first and show us the same error.

If it turns out that it works (against what you say), go to CKBuilder and add the 3rd party plugins that you want, one by one. See which one breaks your installation.

comment:4 Changed 5 years ago by santaclaus21

Resolution: wontfix
Status: pendingclosed

I was pretty sure, that I was checking it twice without 3rd. It seems to you have right ! I've downloaded now standard, basic and full and ACF is working for me now. Strange. So, one (or more) plugins from CKBuilder is crap. Thank you !

Ticket can be close now.

comment:5 Changed 5 years ago by Anna Tomanek

Resolution: wontfix
Status: closedreopened

Great to hear it works for you. Pity you did not listen 3 days ago when we told you so :)

Before I close this one, let me just say that it actually was Reinmar who debugged this (again) today, I merely pasted his answers here because you seemed to be so determined to undermine his competence that you did not bother to check whether he was right. So any thanks should be directed to him and not to me really.

comment:6 Changed 5 years ago by Anna Tomanek

Resolution: invalid
Status: reopenedclosed

comment:7 Changed 5 years ago by santaclaus21

Maybe it will be helpfull for you, a reason was "Style Parser" plugin. After removing them from my build, everything is working like expected. Is that 3rd or CKSource ?

comment:8 Changed 5 years ago by Anna Tomanek

Ah yes, that's true, the Styles Parser plugin is incompatible with ACF due to #10136. Note that this is an optional/ additional plugin that is not included in any of the pre-defined presets -- that's why we were unable to reproduce the issue without information on what exactly you are using.

Anyway, I added a note to the Styles Parser entry in the Add-ons Repository so that it was clear for anyone using the plugin. Thanks for getting back to us on this!

comment:9 Changed 5 years ago by santaclaus21

For that reason I've send at the top of bug build-config list, because I wasn't sure that everything is compatibile with ACF. It's great functional, it's much better to do it on the fly by JS instead to server side what I was going to do.

BTW (offtopic): there is no icons for CodeMirror in Builder. They said me - it's problem with CKE not with plugin.. so I'm forwarding.

cheers.

comment:10 Changed 5 years ago by Anna Tomanek

Glad you like ACF, it is a cool feature indeed. Do note, however, that Advanced Content Filter is not a replacement for server-side security checks and you should always secure your websites by yourself.

As for the plugin icons, I reported it to an appropriate person. Not sure why nobody has ever reported this to us.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy