Opened 5 years ago

Closed 5 years ago

#11352 closed Bug (invalid)

"a" element being removed from markup

Reported by: Mateusz Wielgos Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I recently upgraded CKEditor 3.x to 4.3.0 for a CMS that I am working on. I have the following configuration set:

config.removeFormatTags = '';
config.allowedContent = true;

I re-saved some existing data using the upgraded version. Here is a snippet of a diff:

-<a href="/portfolio/voice-of-mcdonalds"><button>Learn More</button></a></div>
+<button>Learn More</button></div>

The "a" element is being removed from the markup. While this markup is probably not "great", it is allowed in HTML5/4 and XHTML, as far as I know. CKEditor 3.? (don't remember exact version that I was using), allowed this.

I am using Google Chrome, v31.

Change History (3)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
  1. Block level links are only allowed in HTML5. They were invalid in HTML4.
  2. Unfortunately editor doesn't handle block-level links yet. You can read about this in this ticket #7961 which is a part of a larger one #9457.

I'm closing this as duplicate of #9457.

comment:2 Changed 5 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: closedreopened

This is not a duplicate of #9457. HTML5 does not allow buttons inside links. See http://dev.w3.org/html5/markup/button.submit.html#button.submit-constraints

comment:3 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy