Opened 5 years ago

Closed 4 years ago

#11466 closed Bug (fixed)

SCAYT jumps to previous ckeditor instance for second misspelling in Chrome

Reported by: JJ Saecker Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.4.3
Keywords: Blink Cc: tech@…, WebSpellChecker.net

Description

With SCAYT enabled on multiple ckeditors in Chrome, the second time a word is misspelled it jumps to the previous ckeditor instance.

To reproduce you need multiple editors with SCAYT on one page. I reproduced the bug using http://nightly.ckeditor.com/14-01-20-07-05/full/samples/plugins/magicline/magicline.html

  1. Turn SCAYT on in both ckeditor instances
  2. Type a misspelled word into the 1st ckeditor instance
  3. Right click on the misspelled word and correct it
  4. Type the same misspelled word into the 2nd ckeditor instance
  5. Continue to type and it will jump to the 1st ckeditor instance

This happens using Google Chrome Version 32.0.1700.76 m on a Windows 7 Professional PC

Attachments (1)

2014-02-13_1454.swf (1.1 MB) - added by Jakub Ś 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 5 years ago by Jakub Ś

Cc: tech@… WebSpellChecker.net added
Keywords: Blink added
Status: newconfirmed
Version: 4.33.4.3

I was able to reproduce this problem from CKEditor 3.4.3 in Blink browsers only. What is strange is that i wasn't able to get this result in none version below 3.4.3. Perhaps soma change from 3.4.3 conflicts with SCAYT.

Changed 5 years ago by Jakub Ś

Attachment: 2014-02-13_1454.swf added

comment:2 Changed 5 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:3 Changed 4 years ago by Wiktor Walc

Status: confirmedpending

WFM in 4.4.7 (in Chrome)

Last edited 4 years ago by Wiktor Walc (previous) (diff)

comment:4 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

I can't reproduce this ticket as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy