Opened 5 years ago

Closed 5 years ago

#11504 closed Bug (fixed)

When config.fullPage = true, entities are not encoded in editor's output.

Reported by: nikos Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.3.3
Component: General Version: 4.3.2
Keywords: Cc:

Description

When config.fullPage is set to true, latin characters are not transformed to HTML entities. When default / false, latins are transformed correctly.

  1. Add 'config.fullPage = true;' to config.js
  2. Toggling between WYSIWYG and source.

I'm using version 'Full' from the package. Worked in the earlier version, which was some 4.0.x.

Attachments (1)

11504.html (686 bytes) - added by Piotrek Koszuliński 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 5 years ago by Wiktor Walc

Works fine in 4.3.1, so it's a recent regression.

Last edited 5 years ago by Wiktor Walc (previous) (diff)

comment:3 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.3

comment:4 Changed 5 years ago by Piotrek Koszuliński

First bad commit is git:1fcf5f16 (#11372).

Changed 5 years ago by Piotrek Koszuliński

Attachment: 11504.html added

comment:5 Changed 5 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:6 Changed 5 years ago by Olek Nowodziński

Summary: When config.fullPage = true, latin characters are not transformed to HTML entities.When config.fullPage = true, entities are not encoded in editor's output.

comment:7 Changed 5 years ago by Olek Nowodziński

Status: assignedreview

It turned out that ​git:1fcf5f16 is a first good commit because it revealed a bug!

The story is that, while fixing #11372 and introducing nestedEditable context, we assumed that <body> is never processed. Well, in fact, it's never processed unless you set config.fullPage: true, a case that we didn't predict.

If in fullPage <body contenteditable="true"> gets context nestedEditable:true (which is insane) and Entities plugin defined own htmlFilter rule with excludeNestedEditable: true, basically that rule is never executed.

I pushed a simple fix to t/11504 (+tests).

comment:8 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I force pushed rebased branches with little enhancements.

comment:9 Changed 5 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

git:9c7de16 landed in master (107aaa1 tests).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy