Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11512 closed Bug (invalid)

When composing a mail and pressing enter, an extra line is appended

Reported by: Holger Herbert Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

We are using CK editor to compose/format email.

When you enter “John Smith” and press enter key in CK editor CK editor inserts additional blank line.

We are using CK editor to compose/format email.

Repro steps ====== Enter “John Smith” and press enter key in CK editor. You notice that CK editor inserts additional blank line. do the same with shift enter, it does not happen.

The Enter Key has an ASCII value of 13 and Shift+Enter has 10.

In the present scenario, the CK editor appends an additional Shift+Enter (Ascii 10) when user click on Enter Key (which is undesired).

The issue is reproducible @ site ckeditor.com/demo

Change History (3)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed
Version: 4.3.2

Pressing enter inserts new paragraph which is totally correct behaviour. Paragraphs are styled to be separated with a margin, which is not an empty line - it's only visual space. You can change this styling in contents.css.

comment:2 in reply to:  1 Changed 5 years ago by Holger Herbert

Replying to Reinmar:

Pressing enter inserts new paragraph which is totally correct behaviour. Paragraphs are styled to be separated with a margin, which is not an empty line - it's only visual space. You can change this styling in contents.css.

We totally agree that the Enter key causes a new paragraph and that the visual space can be controlled or handled in the CSS file.

The question here is why the Editor is adding a new line character (ASCII 10) additionally only after the last Enter key. in the document.

comment:3 Changed 5 years ago by Piotrek Koszuliński

Unfortunately I don't understand where that \n character appears. Do you mean the data retrieved from editor? If so - what's the problem with that \n character? It's an HTML string - it's insignificant.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy