Opened 6 years ago

Closed 5 years ago

Last modified 3 years ago

#11518 closed Bug (fixed)

Inline Editing Cursor Jump w/ SCAYT Enabled

Reported by: npgroup2000 Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 4.0.1
Keywords: Firefox IE Cc:

Description

I see this happen on our app and also on your demo. If SCAYT is enabled and you click into an inline area to edit, the cursor jumps to the 0 position and needs to be focused into the original position again. Any fixes for this? Behavior w/o SCAYT enabled is fine.

Change History (5)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: Firefox IE added
Status: newconfirmed
Version: 4.0.1

Problem can be reproduced from CKEditor 4.0.1 (when SCAYT for inline editor was made available) in Firefox and IE8-11.

In IE cursor is moved to the end of content.

To reproduce click on editable area, enable scayt and wait - cursor should be moved. Next time you enter this area cursor will always be put to beginning/end.

comment:2 Changed 5 years ago by Wiktor Walc

Component: GeneralUI : Spell Checker

comment:3 Changed 5 years ago by Wiktor Walc

Status: confirmedpending

Is it possible that the issue is gone? I'm unable to reproduce it in FF and IE11, so either the TC is unclear or the issue is no longer valid.

comment:4 Changed 5 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

I can't reproduce it as well.

comment:5 Changed 3 years ago by Nitin Shinde

Issue reproduces when you use enterMode: CKEDITOR.ENTER_BR and having block element like <b> or <span> when using nanospell for spell checking

Fixed my issue by using enterMode: CKEDITOR.ENTER_P

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy