Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11521 closed Bug (invalid)

Several issues

Reported by: Greg Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I took over an application which had a very old version of FCKEditor. I upgraded it to FCKEditor v2.6.5 and it works fine. However, it appears that the older versions are no longer supported, so I upgraded to v4.3.2. That wasn't quite as easy a task as it should have been. Unfortunately, there are so many issues that I am forced to stick with the unsupported version until these issues are fixed.

Using: CKEditor v4.3.2, CKEditorControl v3.6.4

Issue List

  1. Imported Font elements are removed from the HTML and not replaced.
  2. In attempting to get around issue #1, I specified allowedContent for the Font element in the config file. This allowed the Font element to remain in the HTML, but resulted in many of the Toolbar icons to be removed. Not an acceptable solution.
  3. When running the editor in IE under compatibility mode, the Style, Format, Font and Size dropdowns do not appear.

I cannot upgrade to a newer release until this editor works at least as good as the unsupported version. Please let me know when you have added the transformations for the Font element and have fixed the dropdown bug in IE compatibility mode.

I have tried your sample and was unable to duplicate the problem with the dropdown. However, it is not using the CKEditorControl, so the error is probably in that control.

If you can provide me with a supported version number that doesn't have those two problems, I will upgrade to that version until the bugs are fixed.

I have attached a sample page. I am using IE 9 with the Compatibility View turned on.

Attachments (1)

TestCkEditor.zip (787 bytes) - added by Greg 6 years ago.
unable to provide entire project due to 2.9MB limitation. just create a new web site using visual studio, add a reference to the ckeditorcontrol.dll, add the ckeditor folder to the project, then add the files from the attached zip file. Make sure that IE Compatibility View is set on. Run the project and the drop downs will not work. Toggle the Compatibility View and then they will work.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Greg

Attachment: TestCkEditor.zip added

unable to provide entire project due to 2.9MB limitation. just create a new web site using visual studio, add a reference to the ckeditorcontrol.dll, add the ckeditor folder to the project, then add the files from the attached zip file. Make sure that IE Compatibility View is set on. Run the project and the drop downs will not work. Toggle the Compatibility View and then they will work.

comment:1 Changed 6 years ago by Piotrek Koszuliński

Keywords: Font transformation dropdowns IE compatibility mode removed
Resolution: invalid
Status: newclosed
Version: 4.3.2

Regarding font tags - use config.extraAllowedContent to add additional rules to default editor settings. Setting config.allowedContent overrides editor settings - that's why you lost buttons.

Regarding compatibility mode - since this issue is not reproducible on our samples, we cannot confirm a ticket. Additionally (and first of all, actually ;)), we do not support IE compatibility mode and we never did. However, if you have to use compatibility mode, since this mode is pretty similar to IE7 I would advice you to install CKEditor 4.1.3 which is the last supporting it. But IE11 support has been added in CKEditor 4.3, so you have to choose what's most important.

comment:2 Changed 6 years ago by Greg

I switched the allowedContent to extraAllowedContent and the font is working as I expected. Thank you!

I tried switching to v4.1.3. This did not work either. This pretty much points to the cfeditorcontrol, as I had stated previously. Unfortunately, since you do not have a sample using the ckeditorcontrol for .Net I connot verify whether the problem exists or is in my code.

Since you do not support IE compatibility mode, I will have to back up to CKEditor v2.6.5 and FCKEditorControl v2. Since they are unsupported versions and your supported versions do not work within our application, I will have to begin looking for an alternative solution.

It is too bad, as I felt that your control was quite easy to integrate after figuring out the differences between it and the original.

comment:3 Changed 6 years ago by Greg

I tried using previous versions of the CKEditor with the v3.6.4 verison of the CKEditorControl and found that the dropdowns functioned correctly in Compatibility Mode up through v4.0. Starting with v4.0.1, the CKEditor was no longer functioning correctly. I will use v4.0 until you come out with a version that works in compatibility mode again.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy