Opened 5 years ago

Closed 5 years ago

#11535 closed Bug (invalid)

Pasting the text twice

Reported by: Ramu Vellayappan Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.6
Keywords: Cc: Ramu Vellayappan

Description

Hi,

Problem: When I copy and paste plain text using ctrl + v , the content is getting pasted twice.

I have created a custom plugin. The functionality is adding a drop down into the CKEDITOR toolbar. Getting the value from database and attached the click event to it.

In the custom config I have following sett up:

config.pasteFromWordRemoveStyles = true; cconfig.forcePasteAsPalinText = true;

When I paste the content by right click, it is pasting only once and working fine. One more thing I have notice my application is a single page application and I have 3 instance of CKEditor only in one instance the ctrl + v key pasting the content twice. Because only in this instance I have added extra plugin and added the drop down to the toolbar.

I have tested all the above actions in chrome browser and we are using CKEditor version 3.6.6

Could you please advice how to avoid the above mentioned problem. The content should be pasted only once.

Change History (2)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Keywords: ctrl + v pasting content twice removed
Status: newpending

I think that it's more a question for http://ckeditor.com/forums unless you mean that CKEditor has some kind of bug. Also, you wrote about 3.6.6, so we don't even know if it can be still reproduced on latest version.

So, if you think there's a bug in CKEditor, please describe it in a way that will make it possible for us to reproduce it. E.g. attach a working sample. Otherwise, you can ask your question on forum.

comment:2 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I think this has something to do with this custom plugin as this doesn't happen in CKEditor by default.
@ramu.ve your words seem to confirm this. You are getting this error with your plugin only.

My guess is that you might have attached some listener twice thus you get such result.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy