Opened 5 years ago

Closed 5 years ago

#11536 closed New Feature (fixed)

Create htmlDecode - complementary function to htmlEncode.

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.4.0
Component: General Version:
Keywords: Cc:

Description (last modified by Marek Lewandowski)

We're missing htmlDecode funciton in CKEDITOR.tools because we have:

htmlEncodeAttr - which has its complementary function htmlDecodeAttr
htmlEncode - which does not have htmlDecode

It make senese to implement such function.

We may consider to do it in conjuction with t/11536, since it will touch the same thing.

Related issues:

#11480 (currently it has implemented private implementation decodeHtml, so it should reuse tools version) #11442

Change History (6)

comment:1 Changed 5 years ago by Marek Lewandowski

Description: modified (diff)

comment:2 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4
Status: newconfirmed

comment:3 Changed 5 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:4 Changed 5 years ago by Marek Lewandowski

Status: assignedreview

Pushed to t/11536 at dev and t/11536 at tests.

comment:5 Changed 5 years ago by Piotrek Koszuliński

Status: reviewreview_passed

Please enhance test so it checks if 'g' flag was used in regexps. I found myself forgetting about it :D.

PS. It's better to make code style fixes at the beginning of branch, not at the end.

comment:6 Changed 5 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Fixed with git:da5e23cada2a at dev and 4246343793c57 at tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy