Opened 10 years ago

Closed 10 years ago

#11537 closed New Feature (fixed)

Move regexps in html encode/decode functions to separate values

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.4.0
Component: General Version:
Keywords: Cc:

Description

We may move regexps into separate variables that will bring slight performance increase since regexps will be compiled only once.

See perf tests page

This is trivial change and can be done along with t/11536

Change History (3)

comment:1 Changed 10 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4
Status: newconfirmed

comment:2 Changed 10 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: confirmedassigned

comment:3 Changed 10 years ago by Marek Lewandowski

Resolution: fixed
Status: assignedclosed

Fixed with git:aa35091f4b (merged to major) at dev.

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy