Opened 12 years ago

Closed 12 years ago

#1154 closed Bug (invalid)

<br> is removed from the middle of the text

Reported by: alan cook Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.3
Keywords: WorksForMe Pending Cc:

Description

Cross browser editing is removing <br /> tags. (And I have to ask, why are you even touching <br />s? Isn't that just asking for trouble?)

To reproduce:

In Internet Explorer: 1) Enter text 2) Set font on typed text 3) Press shift+enter (to generate a <br />) 4) Type a second line of text 5) Set font on the new line of text 6) Save the data (in our case, to a database)

In Firefox: 1) Load up the same data generated above 2) Save the data

The text will now be on one line.

I'm *assuming* switching to code view will do the same thing as saving the data, but code view is disabled in our app and I have not tested it.

Change History (2)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: WorksForMe Pending added
Summary: <br> is still being removed in 2.4.3<br> is removed from the middle of the text

I'm not able to reproduce it with the 2.4.3.

The following is the output I have from IE7:

<p><font face="Comic Sans MS">Some text<br />
</font><font face="Courier New">more text</font></p>

I have no problems when loading this in FF2. The <br> is preserved. Do you have a different output of it?

Maybe there is something else in your test case that need to be done to see the problem. Let us know more details.

comment:2 Changed 12 years ago by Martin Kou

Resolution: invalid
Status: newclosed

Ticket expired

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy