Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11591 closed Bug (duplicate)

New link does not overwrite old links

Reported by: Piotr Jasiun Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc:

Description

  1. Open "Replace by class" sample.
  2. Select "Neil Armstrong and Buzz Aldrin"
  3. Click link button and create link to "wikipedia.org".
  4. Close dialog (press "ok").
  5. Click in the midile of "Armstrong".
  6. Click link button.

Result: This is still link to "en.wikipedia.org/wiki/Neil_Armstrong". You can see in in source as well:

<a href="http://en.wikipedia.org/wiki/Neil_Armstrong" title="Neil Armstrong">Neil Armstrong</a><a href="http://wikipedia.org"> and </a><a href="http://en.wikipedia.org/wiki/Buzz_Aldrin" title="Buzz Aldrin">Buzz Aldrin</a>

Expectation: New link will overwrite old one.

Change History (6)

comment:1 Changed 6 years ago by Marek Lewandowski

Status: newconfirmed

Confirmed at Opera 19.0.1326.63 @ Win8

comment:2 Changed 6 years ago by Piotrek Koszuliński

I would also expect that link overridden the old ones.

comment:3 Changed 6 years ago by Jakub Ś

Problem can be reproduced from CKEditor 3.0.

Same thing will happen when you select text and link. When you select two links next to each other nothing will get changed.

comment:4 Changed 6 years ago by Jakub Ś

Version: 3.6.6 (SVN - trunk)3.0

comment:5 Changed 6 years ago by Olek Nowodziński

cc

comment:6 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This issue is in fact duplicate of #8470.

Last edited 6 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy