Opened 5 years ago

Closed 5 years ago

#11619 closed New Feature (duplicate)

pasting numbered lists from MS Word - different behavior in CKE3 and 4

Reported by: Stefan Strasser Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Configuration in config.js for this case is

config.forcePasteAsPlainText=true; 

When pasting a formatted numbered list from MS Word (or OpenOffice/LibreOffice) results to a html source code like this:

with CKE 3.6.3

<p>1. first item<br/>
   2. second item<br/>
   3. third item</p>

with CKE 4.3.2

<p>first item<br/>
   second item<br/>
   third item</p>

As you can see, in CKE 3 the numbered list was pasted as "hard coded" numbers, in CKE 4 it is ignored.

If you paste such a list in a text editor (like Windows editor, notepad++) you get the same behavior as in CKE 3.

It would be great if the old behavior from CKE 3 could be available in a future release, maybe controllable via a configuration setting.

Change History (1)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: newclosed

While there's been a change between CKEditor 3.x and CKEditor 4.x we think that it's a change for the better. The forcePasteAsPlainText option is not meant to make CKEditor a plain text editor. Therefore, after pasting a list which was transformed to paragraph user should apply list to that text, otherwise content will be incorrect. So if editor would keep the numbers in a text, then user would have to remove them manually after applying list. Currently user only needs to select text and press list button, so the behaviour is better. Additionally, there are more details (like nested lists) which make keeping numbers/bullets tricky and in result senseless.

However, we understood that the problem may be caused by too strictly working forcePasteAsPlainText. I reported more general ticket for it #11621 and I'm closing this one.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy