Opened 4 years ago

Closed 3 years ago

#11724 closed Bug (fixed)

[Touch devices] Dropdows work unstable

Reported by: Piotr Jasiun Owned by: Szymon Kupś
Priority: Normal Milestone: CKEditor 4.5.4
Component: General Version:
Keywords: Android Chrome iOS Cc:

Description

Tested on CKEditor 4.3.4, Chrome 33 on Android 4.4.2.

When I press style combo to open dropdown:

  • sometimes nothing happens,
  • sometimes list works fine (usually when I press it for the second time),
  • sometimes I lose a selection.

Change History (9)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: Android Chrome added; android chrome removed
Status: newconfirmed

comment:2 Changed 4 years ago by Piotr Jasiun

When I check Android device with a hardware keyboard (Asus Eee Pad Transformer, first generation) I found out that everything is fine as long as the hardware keyboard is plugged in , so probably the reason of this bug is the software keyboard.

comment:3 Changed 3 years ago by Jakub Ś

#13510 was marked as duplicate.

comment:4 Changed 3 years ago by Wayne Christian

On the Galaxy Tab 10, this always seems to result in the dismissal of the software keyboard and loss of the selection

comment:5 Changed 3 years ago by Szymon Kupś

Owner: set to Szymon Kupś
Status: confirmedassigned

comment:6 Changed 3 years ago by Szymon Kupś

Status: assignedreview

Pushed branch:t/11724

Dropdown dismissal was caused by window's resize event that is fired when software keyboard is hiding/showing. Introduced reposition() method in floatpanel plugin. My solution is to reposition the floatpanel on resize event instead of hiding it.

comment:7 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.4

comment:8 Changed 3 years ago by Piotrek Koszuliński

Summary: [Android][Chrome] Dropdows work unstable[Touch devices] Dropdows work unstable

comment:9 Changed 3 years ago by Piotrek Koszuliński

Keywords: iOS added
Resolution: fixed
Status: reviewclosed

Merged to master with git:205e4df. I made only couple of improvements in the manual test. This was kinda brutal solution, but it should do the job and it's logical.

Good job!

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy