Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11752 closed Bug (invalid)

Editor removes [type] attribute on <ol>

Reported by: Danil Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version:
Keywords: Cc:

Description

Type in source mode:

<ol type="a">
	<li>abc</li>
</ol>

Editor forbids type attribute. This is incorrect behavior. See http://www.whatwg.org/specs/web-apps/current-work/multipage/grouping-content.html#attr-ol-type

Additionally, "liststyle" plugin sets css property "list-style-type" instead of "type" attribute. I think this needs to be discussed.

Change History (4)

comment:1 Changed 6 years ago by Danil

It looks like this is caused by ACF. Could anybody point me where to allow forbidden [type] attribute in source code?

comment:2 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.3.5 (GitHub - master)

comment:3 Changed 6 years ago by Danil

Thanks, this works. But is any reason to remove this attribute by default? This causes problems, but I don't see any profit.

comment:4 Changed 6 years ago by Jakub Ś

No plugins reports it to ACF so it isn't allowed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy