Opened 5 years ago

Closed 5 years ago

#11766 closed Bug (invalid)

When closing an Internet Explorer (11) window containing a CKEditor, opened from an external source, a script error occurs

Reported by: infoland Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE11 Cc:

Description

When closing an Internet Explorer (11) window containing a CKEditor, opened from an external source, a script error can occur if the CKEditor is not yet fully loaded:

Access is denied

in: javascript:void(function(){document.open()%3B(function()%7Bfor(var%20a%3B%3B)try%7Ba%3Dwindow.parent.document.domain%3Bbreak%7Dcatch(c)%7Ba%3Da%3Fa.replace(%2F.%2B%3F(%3F%3A%5C.%7C%24)%2F%2C%22%22)%3Adocument.domain%3Bif(!a)break%3Bdocument.domain%3Da%7Dreturn!!a%7D)()%3Bdocument.close()%3B}())

It appears to be the 'document.open' that causes the problem.

Change History (3)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: Access Denied removed
Status: newpending
Version: 4.3.4

Could you provide reduced test-case HTML file showing this problem plus some step by step explanation?

I confused by first sentence, I'm Sorry.

When closing an Internet Explorer (11) window containing a CKEditor, opened from an external source, a script error can occur if the CKEditor is not yet fully loaded:

  • How can you see error if you have closed IE11 window, tab?
  • Did you perhaps mean some modal dialog containing editor?

comment:2 Changed 5 years ago by infoland

A reduced test case is very hard to produce, because it would require creating a new Visio add-in.

The following happens (I will try to describe it more fully).

A user runs Visio 2010 with our company's add-in installed. The user double-clicks on a Visio shape. Visio opens a form (not modal) containing a browser control. This browser control opens a page containing the CK Editor.

If the user closes the form before the CK editor has fully loaded, but after it has started loading, the error as described in the ticket is shown in a 'flat' grey dialog. I am not exactly sure where the dialog originates.

comment:3 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

First of all, this is not a supported environment. CKEditor works in browsers and browsers are supported. A browser controls opened in other applications are not supported and very often they differ slightly from the standard environments - theoretically it is negligible, but in practice it's definitely not. For example your comment describe a race condition which should not cause problems in real browsers, but somehow it does in the browser control.

I'm closing this ticket. We can reopen it if we're able to reproduce it in some environment which we support.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy