Opened 6 years ago

Closed 6 years ago

#11790 closed Bug (duplicate)

[Blink] Chrome - merging block + ACF

Reported by: santaclaus21 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Maybe it's something similar to [9998] bug, but merging blocks doesn't add span, but makes something different:

Before backspace: ` <p>&nbsp;</p>

<header> <h2>Bus Stop Location</h2> </header> `

After backspace: ` <p><strong style="color:rgb(62, 62, 62); font-weight:700; line-height:1.85em">Bus Stop Location</strong></p> `

It's a little strange, because ACF is working with rules: ` config.allowedContent = 'script(*)[*]{*}; *(*); td th[colspan]{border,border-width,vertical-align,width}; table[align, cellpadding, cellspacing, border]{border,border-width,width,margin}; img[alt,!src, border, title, contenteditable]{width,height,float,margin,margin-left,margin-right,margin-top,margin-bottom,border-width}; span iframe embed object param form input select textarea[*]; article{display}; div sup sub header footer section article span table tr td th ol li p h1 h2 h3 h4 h5{font-weight,text-align,text-decoration}; a[*]{font-weight,text-decoration}; *[id]; *[contenteditable,data-animspeedid,data-autostartid,data-openonclickid,data-pictheightid,data-showcontrolid,data-showtitleid,data-slideshowid,data-speedid,data-transitiontypeid]; b i u div blockquote strong hr th em ol ul;'; `

So even if Chromium bug [9998] - it's shouldn't happen because of ACF rules.

Change History (1)

comment:1 Changed 6 years ago by Piotrek Koszuliński

Keywords: chromium blink acf merging removed
Resolution: duplicate
Status: newclosed
Version: 4.3.4

It is duplicate of #9998 (or just a slightly different case). The ACF controls only input HTML and synchronizes editor features, but in this case, backspace unfortunately isn't an editor feature. It's controlled by a browser, and when using Chrome it's just terrible.

From the good news - in a few days we're going to start working on #9998.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy