Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11803 closed Bug (invalid)

Weird behaviour when playing with indentation on list

Reported by: Artur Delura Owned by:
Priority: Low Milestone:
Component: General Version:
Keywords: Cc:

Description

I'm not sure if it's bug but:

  1. Open editor with no content
  2. Create list by clicking adequate button
  3. Play with "Increase indent", "Decrease Indent" buttons

Actual result: List is escaped when we reach indentation level 0, so everything works fine.

Now do this:

  1. Open editor with no content
  2. Increase "empty" content with "Increase Indent" button
  3. Create list by clicking "Insert/Remove Ordered List"
  4. Click "Decrease Indent"

Actual result: List is escaped, but wether it should surely? I think it should be escaped when indentation level reach 0.

Change History (4)

comment:1 Changed 6 years ago by Piotr Jasiun

Status: newconfirmed

I'm also not sure what is expected behavior. We should as some people if we did not do it before.

comment:2 Changed 6 years ago by Artur Delura

Related: #11802

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

The confusion is caused by visual conflict between indentblock and indentlist. In step two of second TC you're adding margin. This margin is then inherited by the list item (actually I think that it should be inherited by ul/ol element, that's another thing). But when you click outdent in the <ul><li>^</li></ul> the outdentlist steps in. That's totally correct, because what was the last action you made? You created list. So first action of outdent is to remove that list.

comment:4 Changed 6 years ago by Piotrek Koszuliński

PS. Listblock is a non-semantic plugin and that's why it makes this confusion. But it's enabled only in full preset. In standard preset the behaviour is totally clear.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy