Opened 5 years ago

Closed 5 years ago

#11812 closed Bug (invalid)

Setting styles does not make effect

Reported by: Artur Delura Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

  1. Open sample:

http://presets.ckeditor.dev/4.4.0/full-all/ckeditor/samples/plugins/stylesheetparser/stylesheetparser.html

  1. Type: ABCD in editor
  2. Set big font size so everything will be better visible
  3. Select ABC
  4. Set style span.markYellow to selection
  5. Select BCD
  6. Set style span.markGreen to selection
  7. Select C
  8. Set style span.markYellow to selection

Actual result: C is still green

Change History (1)

comment:1 Changed 5 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed
Version: 4.1

Well, it's not a bug - it's how styles system works and a matter of conflicting styles. When you click again "mark yellow" in 9th step you're actually removing it, not overriding green marker. So the yellow marker is removed from "C" char what's not visible because the test is green.

The root of problem is that styles system does not support styles excluding each other. In this case, when in 7th step you apply green marker, the yellow marker style should be removed, but it's not, so you have both styles applied at the same time. It's confusing and it's a known limitation reported in other tickets.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy