Opened 5 years ago

Closed 3 years ago

#11818 closed Bug (fixed)

No information displayed in link dialog box when no anchors available

Reported by: Artur Delura Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.0
Keywords: Cc:

Description

Browsers: All

  1. Open editor with no content
  2. Type some word
  3. Select world by double-click
  4. Hit Ctrl + L, to create link tag from text
  5. From "Link type" drop down menu in dialog box select "Link to anchor in the text"

Actual result: Because there are no other anchors in content, adequate information should be displayed as it happend in 4.3.4 version "No anchors available in the document". But in version 4.0.0 nothing is displayed.

Change History (2)

comment:1 Changed 5 years ago by Jakub Ś

Keywords: links removed
Status: newconfirmed

I was able to reproduce this one on major only in IE8, Firefox and Chrome.

In Opera, IE9-11 you can see every part of dialog visible (path that should be only visible after seleting option from dropdown) and browser throws:

TypeError: Object #<Object> has no method 'parseLinkAttributes' 
link.js
line: 856

comment:2 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: confirmedclosed

Can't repro since 4.4.1.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy