Opened 12 years ago

Closed 12 years ago

#1196 closed Bug (fixed)

Scrollbar opens Opera context menu

Reported by: Frederico Caldeira Knabben Owned by: Hallvord R. M. Steen (Opera Software)
Priority: Normal Milestone: Opera Compatibility
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Cc: Hallvord R. M. Steen (Opera Software)

Description

Steps to Reproduce

  1. Open sample01.html;
  2. Click the "Style" combo in the toolbar to open it;
  3. Double-click the scrollbar on it. The default Opera context menu will come up.

I've faced this problem when trying to quickly scroll down by clicking the scroll button in the scrollbar.

Change History (4)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

BTW, tested with Opera 9.5 build 9507.

comment:2 Changed 12 years ago by Aleksey Onopriyenko

Seems like context menu is opened only if some text in the list has been selected (during double-clicking or before).

comment:3 Changed 12 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

Probably depends on Opera's bug 87804, "event.preventDefault() does not stop hotclick context menu from appearing"

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Works for me with Opera build 9660.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy