Opened 4 years ago

Closed 3 years ago

#11993 closed Bug (fixed)

Pasting content scrolls document in Google Chrome

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.0
Keywords: Support Cc: harry@…

Description

Reported through support channel:

We are seeing a scroll issue after pasting text into the CKEditor rendered in a div with a vertical scrollbar. After pasting, the page is scrolled to the bottom of the view.

This happens in Chrome. It does not happen in IE 11 or FireFox.

I was able to confirm this using the attached sample. Copy a single line of text and paste it into CKEditor.

I reproduced this in CKEditor 4.4.1 and 4.0

Attachments (1)

replacebycode.html (1.9 KB) - added by Wiktor Walc 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by Wiktor Walc

Attachment: replacebycode.html added

comment:1 Changed 4 years ago by Wiktor Walc

Status: newconfirmed

comment:2 Changed 4 years ago by Wiktor Walc

Cc: harry@… added

comment:3 Changed 4 years ago by Piotrek Koszuliński

Unfortunately the hack we are using to intercept pasting cannot be further improved, so in specific situations it will cause scrolling. The only solution I see is finally switching to using paste event (and data transfer object carried by it), what we're planning in CKEditor 4.5.

comment:4 Changed 4 years ago by Wiktor Walc

Keywords: Support added

comment:5 Changed 4 years ago by Wiktor Walc

Milestone: CKEditor 4.5.0

It looks like the issue is gone already (major, c8ffa119). Setting the milestone to 4.5.0 to catch regressions.

comment:6 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

I confirmed that now (on git:fb2942a), when we've got most of the pieces in place, everything works fine.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy