Opened 4 years ago

Closed 4 years ago

#12008 closed Bug (fixed)

[Nested widgets] Error thrown when pasting widget with nested editable into nested editable

Reported by: Olek Nowodziński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.5.0 Beta
Component: General Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

Part of #10931.

There's an error thrown while pasting block Image2 widget into Simple Box

Uncaught TypeError: Cannot read property 'filter' of undefined widget/plugin.js:2116

followed by an avalanche of errors during the navigation.

Change History (8)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Jakub Ś

NOTE: filter is just first of properties. If you then click in editor content area you get information about removeClass and equals being unavailable as well (focusedEditable is undefined).

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:3 Changed 4 years ago by Piotrek Koszuliński

Description: modified (diff)
Summary: [Nested widgets] Clipboard issues[Nested widgets] Error thrown when pasting widget with nested editable into nested editable

comment:4 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:5 Changed 4 years ago by Piotrek Koszuliński

Wow. This is a tricky issue. The problem is caused by editor.insertHtml() trying to select nested editable after pasting widget rather than selecting it as we do later. It create a erroneous situation in which we try to put selection to nested editable of not yet initialised widget. We'll either need to fix insertHtml() or leave a hack that detects and handles this situation in widget system.

I will first check if insertHtml() can be fixed.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.0
Status: assignedreview

Pushed branch:t/12008. I fixed insertHtml() what fixed this case. Note - fix does not cover IE8. Very likely we'll not support nested widgets in IE8 for some time. I'll add failing test to regressions.

comment:7 Changed 4 years ago by Olek Nowodziński

Status: reviewreview_passed

Pushed µCommit with fixed code-style.

comment:8 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on major with git:c17735f.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy