Opened 5 years ago

Closed 5 years ago

#12021 closed Bug (invalid)

Cannot insert "é" character using AltGr-combination with Internet Explorer

Reported by: davidegeland Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Cannot insert the character "é" using Internet Explorer v10 and v11 by using AltGr+\+e (Norwegian keyboard). This works fine in FF and Chrome.

Change History (8)

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending
Version: 4.4.1

I have tried Norwegian Nynorsk, Bokmal language setting with Norwegian Keyboard and both of them have inserted € character in every browser including IE10+. Such character is included everywhere even in native textarea.

Could you tell me what Operating System you use, and which language setting have you used and what exactly do you mean by "cannot insert character" - you can't insert anything or something else is inserted?

comment:2 Changed 5 years ago by davidegeland

I also get the '€' character with Ctrl+e, but what I'm after is the 'é' character.

In FF and Chrome I get the 'é' character with Ctrl + \ + e. In IE this only produces a normal 'e' character.

comment:3 Changed 5 years ago by davidegeland

The operating system is Win 8.1 with IE 11. I've also gotten reports that this happens on Win 7 with IE10 as well.

comment:4 Changed 5 years ago by Jakub Ś

In FF and Chrome I get the 'é' character with Ctrl + \ + e. In IE this only produces a normal 'e' character.

Please tell me which Norwegian langugae setting you use (Nynorsk or Bokmal) and which keyboard?
I have tried in every browser nad simply can't instert é character anywhere with Ctrl + \ + e.
On default Win 7 with default browser in CKEditor or even in plain textarea when you type these characters you get focus moved to browser URL bar. This was consistent thus I don't see editor issue here but rather some invalid shortcut problem.
Nevertheless I'm very curious how you have managed to insert this character in browsers like chrome or FF.

NOTE: The only consistent solution that has worked everywhere for me was first method from this link: http://www.rootsweb.ancestry.com/~norway/Characters.html

comment:5 Changed 5 years ago by davidegeland

I'm very sorry, but there was apparently a typo, the key combination should be AltGr + \ + e. The language setting I use is Bokmal, but should be the same with Nynorsk.

comment:6 Changed 5 years ago by Jakub Ś

I was testing both configurations in fact. Keys Ctrl + \ + e don't work - this shortcut puts focus on Browser URL bar. Keys AltGr+\+e insert in my case '€' character. Like I have said before, in my case this behaviour is consistent; I got same results in CKEditor and plain textarea in every browser.

I can't get same result as you did and insert this character with AltGr+\+e shortcut into Chrome or Firefox.

@davidegeland I will ask others ot check if they get same results as you. In the meantime could you to check this behaviour in plain textarea or plain div with contenteditable="true" attribute? Are you getting same results in plain HTML where no CKEditor code is used?

comment:7 Changed 5 years ago by davidegeland

Seems like there's a problem entering the é character in plain textareas with IE as well. So it's probably not a CK specific error after all. It works fine in FF and Chrome.

With IE, I can enter the é character in the URL bar, but not in textareas.

comment:8 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I had a feeling that this might be some native problem. This of course makes this ticket invalid but @davidegeland, could I ask you to check Alt+0233 (numbers on numeric keyboard). This is method 2 mentioned under this link: http://www.rootsweb.ancestry.com/~norway/Characters.html.

It has worked in my case so maybe it will work in yours and could be used as general workaround.

NOTE: Alt, type numbers on numeric keyboard and once you lift Alt key up, character will be inserted.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy