Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12051 closed Bug (invalid)

Misbehaviour of paste option in CKEditor

Reported by: rishi Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version:
Keywords: Cc: nehru.chandrasekaran@…

Description

There is a issue in pasting option,

If we have pasted more than two times, the paste option is misbehaving like pasting the empty spaces instead of cut/copy content.

Attachments (3)

paste.zip (37.9 KB) - added by rishi 5 years ago.
2014-06-04_1150.swf (1011.5 KB) - added by Jakub Ś 5 years ago.
Config_Screen_Shot.zip (229.8 KB) - added by rishi 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by Jakub Ś

Status: newpending
Version: 4.4.0

Please provide the build-config.js file, data you paste and screen cast for this issue or at least plain step by step scenario that explains what to do.

comment:2 in reply to:  1 Changed 5 years ago by rishi

Replying to j.swiderski:

Please provide the build-config.js file, data you paste and screen cast for this issue or at least plain step by step scenario that explains what to do.

Steps to reproduce the issue,

1) Type some content on to the editor 2) select some text from the editor and perform Ctrl+C/Ctrl+x from the editor. 3) Now using Ctrl+V pasting the content in the editor, pasting empty spaces instead of copy/cut content when paste is used more than twice.

comment:3 Changed 5 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I have tried this issue on demo, default editor with different enter modes and nothing weird happened. I'm closing this issue as invalid.

@Rishi if you don't agree please explain exactly what configuration you have that allows you reproducing this error with steps mentioned in previous comment.

If you have any third-party plugins, please uninstall them and try again.

Changed 5 years ago by rishi

Attachment: paste.zip added

comment:4 Changed 5 years ago by rishi

@swiderski

1) If the user cuts the some lines of content 2) User clicked the paste option.

The pasting content is an empty line space.

Please check the paste.zip from the attachment.

comment:5 Changed 5 years ago by rishi

Version: 4.4.0

comment:6 Changed 5 years ago by rishi

This issue is similar to the Ticket #12025. Can you please validate and let me know the comments on it.

comment:7 Changed 5 years ago by Jakub Ś

Please tell me in which browser you get this and if you are able to reproduce this issue on our demo page http://ckeditor.com/demo. If not, I will not continue this issue. i have tried several times and to me it looks all good.

If you think otherwise please explain in detail

  1. What browser does it concern?
  2. What CKEditor configuration? What config options have you used and please send your build-config.js
  3. Please also send screen cast (e.g. jing video) showing your TC steps.

I'm attaching my reproduction steps so that you could see that everything is ok. If I have missed anything in that video, please tell me what it was.

Changed 5 years ago by Jakub Ś

Attachment: 2014-06-04_1150.swf added

comment:8 Changed 5 years ago by rishi

Please check the attachment Config_Screen_Shot.zip for build-config.js,config.js and screen cast showing my TC steps.

Changed 5 years ago by rishi

Attachment: Config_Screen_Shot.zip added

comment:9 Changed 5 years ago by Jakub Ś

Version: 4.4.0
  1. You are right your issue looks very similar to #10225
  2. From what I have checked you are both using CKEditor standard mode with wordcount plugin.

Word count plugin is third-party plugin and I know that some issues were reported for it. It is possible that this plugin (perhaps plus something in your application e.g. third-party script) is causing this behaviour.
Please also try removing this plugin, clearing IE cache (this is not Ctrl+F5) and then checking your sample again.

Please note that your IE (you haven't mentioned till now which one you use) is displaying message that errors have occurred on page. You should check them with IE dev-tools.

You haven't also told me if you are able to reproduce this issue on demo page or not. I have tried many times and haven't managed to do it thus I rather 100% convinced this issue is invalid and caused by your specific implementation.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy