Opened 3 years ago

Closed 22 months ago

#12077 closed New Feature (fixed)

Add support for HTML5 "download" attribute in link (a) elements

Reported by: uwolfer Owned by: s.kups
Priority: Normal Milestone: CKEditor 4.6.0
Component: General Version: 4.0
Keywords: Cc:

Description

It would be nice to have a checkbox for setting the download attribute for a elements in the link dialog (tab: "Target").

Additionally, an optional text-field could be added for setting the suggested name of a download.

See also:

Change History (7)

comment:1 Changed 3 years ago by m.lewandowski

This attribute seems to be handled by Chrome and FF so far, IE11 still doesn't handle it according to caniuse.

comment:2 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version set to 4.0

Confirmed.

Additionally, an optional text-field could be added for setting the suggested name of a download.

I believe this issue os covered here: http://dev.ckeditor.com/ticket/11277

comment:4 Changed 2 years ago by Reinmar

  • Milestone set to CKEditor 4.6.0

comment:5 Changed 22 months ago by s.kups

  • Owner set to s.kups
  • Status changed from confirmed to review

comment:6 Changed 22 months ago by s.kups

I merged changes into major branch with git:6eaa9e4.

I've added tests and requiredContent field for the checkbox so it can be activated/deactivated by content filter.
Closed PR: ​https://github.com/ckeditor/ckeditor-dev/pull/129.

comment:7 Changed 22 months ago by s.kups

  • Resolution set to fixed
  • Status changed from review to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy